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1  Important Information

1.1  Brief Description of DS-Win V4

DS-Win V4 is an electronic phone directory designed for attendant consoles and 
office workstations. It consists of DS View for the application as well as GUI 
Designer and DS Admin for customization and modifications. It has been 
designed on the basis of the latest technical know-how and is extremely user-
friendly. The wide range of features provided by DS-Admin allows you to 
configure your telephone directory to suit your special requirements and thus 
optimize it for your work.

1.2  Target Group and Requirements

This Service Manual is intended for service technicians and administrators who 
want to provision the DS-Win V4 application in combination with Exchange or 
Lotus for end users.

The service technician or administrator should be familiar with the administration 
of the following operating systems:

• Windows 2000/2003

• Windows Vista, Windows 7

• Linux

• Exchange

• Lotus/Domino

1.3  Working with this Service Manual

1.3.1  Reference Manuals

More information on DS-Win V4 can be found in the following documentation:

• DS-Win V4, Administration, Administration Guide A31003-G6640-M100-*-
**A9

• DS-Win V4, DS View, User’s Guide, A31003-G6640-U100-*-**19

• DS-Win V4, GUI Designer, User’s Guide, A31003-G6640-U101-*-**19
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1.3.2  Notational Conventions

The following notational conventions are used in this Service Manual:

Purpose Presentation Example

Highlight important aspects of descriptive text Bold Do not delete Name.

User Interface elements to be used Bold Click OK.

Menu sequence Bold -> Bold File > Exit

Texts located in files and texts to be entered 
into or selected from input or selection fields.

Courier and Bold Word1 Word2 Word3

Placeholders In angle brackets 
and in italics

<InstDir>

Files and directories containing files Courier <InstDir>/config/services/global.cfg

Work steps and substeps in instructions Numbered and 
nested lists

1. Select the SIP registrar check box. The input 
fields are enabled.

2. Set the following:

a) Select the Authentication radio button.

b) Fill in the following input fields:

• SIP-UserID: (e.g.,  hipath3000br13

• Realm: Enter the name of the realm to 
which the authentication applies (e.g.,  
sol.

3. Click Apply. The changes are saved.

Settings that need not always be made in 
sequence

Bulleted list

NOTE: Identifies useful notes.
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1.4  Safety Information and Warnings

Make sure you have read and noted the following safety information and 
warnings before installing and starting up the communication system or device.

Make sure that you also read and follow all safety information and warnings 
printed on the communication systems and devices.

You should also obtain information concerning the emergency numbers.

Types of Safety Information and Warnings

This Service manual uses the following levels for the different types of safety 
information and warning:

7 DANGER

Indicates a universally dangerous situation that can cause death or serious 
injuries.

7 WARNING

Indicates a potentially dangerous situation that can cause death or serious 
injuries.

7 CAUTION

Indicates a dangerous situation that can cause injuries.

NOTE:  Important: Indicates situations that can result in property damage and/
or data loss.
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Further Symbols for Determining the Source of Danger in Greater Detail

The following symbols are not generally used in the manual. They are an 
explanation of the symbols that may be depicted on the communication systems.

* Electrostatic discharge

Electricity Weight Heat Fire Chemicals ESD* Laser
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1.5  Proper Disposal and Recycling

All electrical and electronic products should be disposed of separately from the municipal waste stream 
via designated collection facilities appointed by the government or the local authorities.

The correct disposal and separate collection of your old appliance will help prevent potential negative 
consequences for the environment and human health. It is a precondition for reuse and recycling of used 
electrical and electronic equipment.

For more detailed information about disposal of your old appliance, please contact your city office, waste 
disposal service, the shop where you purchased the product or your sales representative.

The statements quoted above are only fully valid for equipment which is installed and sold in the countries 
of the European Union and is covered by the directive 2002/96/EC. Countries outside the European Union 
may have other regulations regarding the disposal of electrical and electronic equipment.

Used accumulators and batteries with this sign are valuable economic goods and must be recycled. Used 
accumulators and batteries that are not recycled must be disposed of as hazardous waste with full 
observance of all regulations.
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1.6  Data Protection and Data Security

This system processes and uses personal data, e. g., for call charge metering 
purposes, the displays, and for recording user data.

In Germany, the processing and use of such personal data is subject to various 
regulations, including  the regulations of the Federal Data Protection Law 
(Bundesdatenschutzgesetz = BDSG). For other countries, please follow the 
appropriate national laws.

The aim of data protection is to protect the rights of individuals being affected by 
use of their personal data.

In addition, the aim of data protection is to ensure that data is not corrupted when 
processed and that one’s own interests and the interests of other parties that 
need to be protected are not affected.

The customer is responsible for ensuring that the system is installed, 
operated and maintained in accordance with all applicable labor laws and 
regulations and all laws and regulations relating to data protection, privacy 
and safe labor environment.

Employees of Unify GmbH & Co. KG are bound to safeguard trade secrets and 
personal data under the terms of the company’s work rules.

It is imperative to observe the following rules to ensure that the statutory 
provisions relating to service (on-site or remote) are strictly followed. You will not 
only maintain the interests of your/our customers, you will also avoid personal 
consequences.

Contribute to the maintenance of data protection and data security with 
your conscious action:

• Ensure that only appropriately authorized persons have access to customer 
data.

• Take full advantage of all options of allocating passwords; do not inform 
unauthorized persons of passwords, for example by means of a written note. 

• Ensure that no unauthorized person is able to process (store, modify, 
transmit, block, delete) or use customer data in any way.

• Prevent unauthorized persons from gaining access to storage media such as 
backup CDs or log printouts, for example.  This is applicable for service calls 
as well as for storage and transport.

• Ensure that data media that are no longer required are completely destroyed. 
Ensure that no papers remain generally available.

Work together with your contacts at the customer premises. This creates 
mutual confidence and reduces your own workload.
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1.7  Documentation Feedback

If you have questions that are not answered by this document:

• Internal employees should contact their National Support Center.

• Customers should contact their retailer or the Unify Customer Support 
Center.

When you call, state the title, ID number, and issue of the document.

Example:

• Title: DS-Win V4, Service Manual

• Reference number: A31003-G6640-S100-4-7620



Important Information

DS-WinSH_ch01.fm

Documentation Feedback

 A31003-G6640-S100-4-7620, 01/2018
14 DS-Win V4, Service Manual, Service Manual

        



DS-WinSH_ch02.fm

Hardware and Software Requirements

Minimum PC Requirements

A31003-G6640-S100-4-7620, 01/2018
DS-Win V4, Service Manual, Service Manual 15

         

2  Hardware and Software Requirements

Before you install DS-Win V4 on a PC, make sure that the software and hardware 
fulfil the necessary requirements as described in the following sections:

Section 2.1, „Minimum PC Requirements“

Section 2.2, „Applications and Phones for Automatic Dialing“

Section 2.3, „IBM Notes/Domino Server“

2.1  Minimum PC Requirements

The used PC for DS-Win must fulfill the following minimum requirements:

• Processor Pentium 4 with 1.7 GHz or similar

• 2 GByte main memory

• Hard disk capacity:

– 80 GByte

– Min. 256 MByte free memory

Additional hard disk space is required if the database becomes larger due to 
more data records.

• 1 DVD ROM drive

• 1 LAN controller

• 19" monitor

• Operating systems:

– Microsoft Windows Vista Enterprise 32-Bit, min. SP1

– Microsoft Windows Vista Business 32-Bit, min. SP1

– Microsoft Windows 7 Professional 32-Bit

– Microsoft Windows 7 Enterprise 32-Bit

– Microsoft Windows 7 Ultimate 32-Bit

The printers available under the operating systems listed can be used to print 
out phone books and records.
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2.2  Applications and Phones for Automatic Dialing

The following applications and phones are supported for automatic dialing:

• AC-Win IP (Attendant console)

• Phones which are supported by CallBridge TU:

– OpenStage 30 T

– OpenStage 40 T

• Phones which are supported by CallBridge IP:

– OpenStage 60 T

– OpenStage 80 T

– OpenStage 15 HFA

– OpenStage 20 HFA

– OpenStage 40 HFA

– OpenStage 60 HFA

2.3  IBM Notes/Domino Server

Requirements with respect to the IBM Notes/Domino Server:

• A Lotus Domino Server 8.5 is required.

• The HTTP and DIIOP server processes must be started.

The processes can also be started later using console commands.

• The notes.ini file must include the following line:

ServerTasks=<Taskname>,http,diiop

• Use of the Domino server console for displaying the configuration (default 
port is 63148):

tell diiop show config

• The IP address and port can be set in the Domino administrator command:

Configuration/Current Server document/Internet 
Protocols/DIIOP
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3  Installation and Licensing

Overview

This chapter describes the installation and licensing of DS-Win; and also 
describes the required databases and applications.

Contents

You find the following topics in this chapter:

Section 3.1, „Installation and Licensing of DS-Win V4“

Section 3.2, „Installing, Activating, and Configuring SNMP Traps“

Section 3.3, „Installing Standard Database and Data Stock“

Section 3.4, „Installing "Export Table Client"Application [Import/Export API (XIE)]“

3.1  Installation and Licensing of DS-Win V4

Overview

After provisioning the installation requirements, the DS-Win V4 application, the 
required database, and the iReport printing application will be installed. 
Thereafter, DS-Win V4 must be licensed. These tasks are described in the 
following sections.

Contents

You find the following topics in this section:

Section 3.1.1, „Checking «Secondary Logon» Windows Service“

Section 3.1.2, „Providing and Starting the DS-Win V4 Installation Files“

Section 3.1.3, „Installing DS-Win V4“

Section 3.1.4, „Licensing DS-Win V4“

3.1.1  Checking «Secondary Logon» Windows Service

To provide the correct operation of DS-Win V4, the "Secondary Logon" windows 
service must be started in Windows and must run automatically. Make sure that 
this service is correctly set:
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For Windows XP

1. Select Start -> Execute and enter services.msc. The "Services" window 
opens.

2. Search under "Services (Local)" -> "Extended" tab for the "Secondary Logon" 
service and check whether the service is started. If not:

a) Restart the service.

b) Set the "Automatic" auto start type.

For Windows 7

1. Click the Windows icon -> Programs -> Search files and enter 
services.msc. The "Services" window opens.

2. Search under "Services (Local)" -> "Extended" tab for the "Secondary Logon" 
service and check whether the service is started. If not:

a) Restart the service.

b) Set the "Automatic" auto start type.

3.1.2  Providing and Starting the DS-Win V4 
Installation Files

Via Download from the SWS Server

1. Download the DS-Win V4 installation files from the SWS server.

2. Unpack the file into a folder.

3. Start the DS-Win V4 R<x>.<xx.x>\Software\install.bat file. The 
welcome screen of the DS-Win V4 installation application opens.

Further Processing: 
Refer to Section 3.1.3, „Installing DS-Win V4“.

From External Medium

If the DS-Win V4 installation files are already stored on an external medium, e. g., 
USB stick, CD, DVD, or external hard disk drive, proceed as follows:

1. Directly start the install.bat file from this medium. The welcome screen 
of the DS-Win V4 installation application opens.

Further Processing: 
Refer to Section 3.1.3, „Installing DS-Win V4“.
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3.1.3  Installing DS-Win V4

Prerequisites

The install.bat file was started and the welcome screen of the DS-Win V4 
installation application is displayed.

Procedure

1. Click Next >. The window opens which is used to select the installation folder.

2. Select one of the following options to set the installation folder:

• Changing the installation folder: Click Change...  
Select the installation folder and click OK. Then, click Next >.

• Take the preset installation folder (C:\Program Files 
(x86)\Siemens\DS-Win V4\): Click Next >.

NOTE:  Important: If Windows in cooperation with DS-Win V4 recognizes the 
(x86) entry in the path name (C:\Programm Files (x86)\...) as an 
attribute and therefore cancels the synchronization with the OpenScape 4000 
Assistant/Manager, the preset installation folder must be avoided.

The window opens which is used to select the installation type. There are the 
following installation types:

• Complete 
All features of DS-Win V4 are installed. This option is used for single work 
stations as well as for administrator work stations (Master PC).

• Client 
The DS-Win data view window is only installed; but not the DS-Win 
administration application or the DS-Win Designer.

• Custom 
You can select the features to be installed and the installation folder.

3. Click Next >. The window opens which is used to install and select Java 
Runtime Environment. If several Java versions are available on the PC, you 
can select the required version.

4. Click Next >. The window opens which is used to start the installation.

Via the < Back button, you can revise the installation settings.

5. Click Install. The DS-Win V4 installation is processed according to your 
settings. If you selected the "Custom" option, you must define the features 
which shall be installed and the installation folders.

During the installation, the following notes are displayed:

– Note which informs about the installation status.
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– Note which informs that the PostGreSQL database and the iReport 
printing application can be installed.

– Note which informs that the "Secondary Logon" service must be started 
to use the PostGreSQL database.

6. Confirm the displayed advisory notes with OK. After the installation, a window 
opens which informs that the installation was finished.

7. Complete the installation with Finish. DS-Win V4 is completely installed now.

Results

• DS-Win V4 was installed in the defined installation folder: C:\Program 
Files (x86)\Siemens\DS-Win V4\

• A data folder was created which DS-Win V4 uses to store the data (in 
Windows Vista and Windows 7): 
C:\ProgramData\Siemens\DS-Win V4\

• DS-Win V4 can be started via: Start -> Programs -> DS-Win V4. In this 
folder, there are the following applications: Database Migration, DS-
Win Admin, DS-Win Configuration, DS-Win, GUI Designer, Uninstall DS-Win 
V4

Important: The installation folder and the data folder depend on the Windows 
version. Also, a different installation folder can be selected. In the following 
sections, the folder names are therefore abbreviated as follows:

• C:\Program Files (x86)\Siemens\DS-Win V4\ ->  
<InstDir>\DS-Win V4\

• C:\ProgramData\Siemens\DS-Win V4\ ->  
<DataDir>\DS-Win V4\

Further Processing

In the next step, DS-Win V4 must be licensed. For this purpose, continue with 
Section 3.1.4, „Licensing DS-Win V4“.
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3.1.4  Licensing DS-Win V4

Overview

DS-Win V4 must be licensed. A license file is required for operation. This license 
file can be provided locally or centrally.

Selecting Procedure

Select one of the following options, and continue with the corresponding section:

• Section 3.1.4.1, „Locally Licensing DS-Win V4“

• Section 3.1.4.2, „Licensing DS-Win V4 Via a Central License Server“

3.1.4.1  Locally Licensing DS-Win V4

Installing Local Central License Agent (CLA)

The CLA files are stored in the DS-Win V4 installation folder.

1. Start the <InstDir>\Software\Licensing\CLA\setup.exe file. The 
welcome screen of the CLA installation application opens.

2. Click Next >. The window opens which is used to select the installation folder.

3. Select one of the following options to set the installation folder:

• Changing the installation folder: Click Change...  
Select the installation folder and click OK. Click Next >.

• Take the preset installation folder: Click Next >.

The window opens which is used to set the users. Select a user login for the 
CLA in this window. There are the following user logins:

• "Standard user". An already existing standard user is selected.

• "New user". A new user must be defined in the <user name>@<domain 
name> format.

4. Click Next >. The service configuration window opens. Enter the following 
data in this window:

– Service port number in the 1024 - 65535 range; the default value is 
61740.

– Size of the error log in days, i. e., how many days an error log is written. 
In the 1 - 365 range; the default value is 180.

– Size of the configuration log in days, i. e., for how many days configuration 
changes are logged. In the 1 - 365 range; the default value is 180.

5. Click Next >. The window opens which is used to start the installation.
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Via the < Back button, you can revise the installation settings.

6. Click Install. The CLA installation is started according to your settings. After 
the installation, a window opens which indicates that the installation was 
finished.

7. Complete the installation with Finish. The CLA is installed now.

Providing the License File to DS-Win V4

1. Copy the license file into the 
<InstDir>\Software\Licensing\License Agent\import folder. In 
this folder, the DS-Win V4 license file will be read and activated.

No further steps are required.

3.1.4.2  Licensing DS-Win V4 Via a Central License Server

1. Open the DS-Win Configuration via Start -> DS-Win V4 -> DS-Win 
Configuration. The DS-Win configuration page for the license server and the 
SNMP settings opens.

2. Switch to the CLA tab. The setting options for the central license server (CLC) 
and the connection parameters between CLC and CLA are displayed. Enter 
the following data in this window:

"License server"

– "CLA host name or IP address": Host name or IP address of the license 
server in the IPv4 format.

– "CLA port number": Port number of the license server. The default value 
is 61740.

"Connections parameters"

– "Timeout value used in CLC-CLA communication (in milliseconds)": The 
default value is 4000. This value can be used; change if required.

– "Retry value used in CLC-CLA communication": The default value is 10. 
This value can be used; change if required.

3. Click Save. Your settings are saved.

Further Processing

In the next step, the SNMP traps will be activated; refer to Section 3.2, „Installing, 
Activating, and Configuring SNMP Traps“.
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3.2  Installing, Activating, and Configuring SNMP Traps

SNMP traps are unrequested messages from an agent (in this case: DS-Win 
View V4) to an SNMP management application which runs on a monitoring 
station, and indicate that an event occured. DS-Win View V4 sends an SNMP 
trap, e. g., if it is started, is closed, and if errors occur (e. g. if the connection to AC-
Win or to the database is lost).

Prerequisite

Check whether the "SNMP Trap" Windows service runs on the DS-Win V4 
computer. If it does not run, activate or install it. The installation and activation of 
this service is described in a Word file which was added to the DS-Win V4 
program files. Refer to the installation directory of DS-Win V4.

Procedure

1. Open the DS-Win Configuration via Start -> DS-Win V4 -> DS-Win 
Configuration. The DS-Win configuration page for the license server and the 
SNMP settings opens.

2. Select the SNMP tab. The options to activate and set the SNMP traps are 
displayed. Enter the following data in this window:

– "Sending SNMP traps": Mark this checkbox if DS-Win View V4 shall send 
SNMP traps to the monitoring station.

"Trap generator properties":

– "Destination Host": IP address of the monitoring station in the IPv4 format

– "Destination Port": Port of the monitoring station

– "Agent address": IP address of the computer on which DS-Win V4 runs, 
in the IPv4 format

"Trap properties":

– "Cluster": e. g., "DS-Win View V4"

– "Hostname": IP address of the monitoring station to which the traps shall 
be sent, in IPv4 format

– "Service ID": specific to the system

– "Global unique ID": specific to the system

– "Error code": specific to the system
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3.3  Installing Standard Database and Data Stock

Supported Databases

DS-Win V4 supports the following databases:

• PostGreSQL

• Informix MySQL 5

• Microsoft SQL Server 2005 Express

• Oracle Database

The DS-Win V4 standard database is PostGreSQL. PostGreSQL can either be 
installed based on the DS-Win V4 installation data, or, an already existing 
database server can be used. In both cases, an example database for DS-Win 
V4 View is created. In addition, an Informix MySQL 5 or a Microsoft SQL Server 
2005 Express example database can be created via an already existing database 
server.

Selecting Procedure

Select one of the following options, and continue in the appropriated section:

Section 3.3.1, „Creating PostGreSQL Example Database Based On the 
Installation Data“

Section 3.3.2, „Creating Example Database With an Existing Database Server“

Section 3.3.3, „Migrating or Activating an Already Existing Database“

3.3.1  Creating PostGreSQL Example Database Based 
On the Installation Data

In this section, the installation of PostGreSQL under Windows 7 is described. An 
example database for DS-Win V4 View is installed during installation.

Procedure

1. Open a shell in Windows with administrator permissions (right-click to the 
prompt -> Run as administrator).

2. Confirm the Windows confirmation prompt with Yes.

3. In the shell, enter the folder into which the PostGreSQL was saved.

4. Execute the Install.bat command. A silent installation of the 
PostGreSQL server starts.
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3.3.2  Creating Example Database With an Existing 
Database Server

If a database server was already installed, an DS-Win V4 example database can 
be also created by the execution of the following scripts:

NOTE:  Important: You must check if command changes are required before 
you use a script. No changes are required for PostGreSQL.

3.3.3  Migrating or Activating an Already Existing 
Database

Procedure

1. Start the GUI Designer.

2. Via Datenbase -> Configure..., start the Data Resource Manager.

3. Select the Database Connections tab.

4. Enter the database or schema name into the "URL" field.

5. Click Apply. Your settings are saved.

Windows Authentication

If the Microsoft SQL Server 2005 Express database is used, DS-Win V4 supports 
the Windows authentication. To use this authentication, set the Integrated 
Security Parameter to true. After this action, special logon and password are no 
more required. If another database server (MySQL or PostGreSQL) is used, 
select the connection, or create a new one.

• for PostGreSQL server PostGreSQL\run_dbScript_pg.bat

• for MySQL 5 server mysql5.0\run_MySql_script.bat

• for Microsoft SQL Server 2005 Express mssql2005\run_SqlServer_script.bat
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3.4  Installing "Export Table Client"Application [Import/Export API (XIE)]

Overview

You need the "Export Table Client" application of "Import/Export API (XIE)" to 
transfer data from OpenScape 4000 Assistant or OpenScape 4000 Manager to 
DS-Win.

This application must be installed on the PC where DS-Win runs. The installation 
application creates the XIE interface.

You find further information on "Import/Export API (XIE)" in: OpenScape 4000 
Manager V8, Import/Export Interface (XIE) API.

Procedure

1. Start the OpenScape 4000 Assistant or OpenScape 4000 Manager, and 
select Utilities -> Import/Export API (XIE) in the tree.

2. Install "Export Table Client":

a) Click Install Export Table Client. The "Import/Export API Installation" 
page opens.

b) Click the Export Table Installation-File link. The "File Download" 
window opens which is used to download the ExTable.exe file.

c) Click Save to store the file. The "Choose Install Location" window opens.

d) Select the required installation folder via Browse, and click OK. The 
ExTable.exe file is stored into the selected installation folder.

e) Double-click the ExTable.exe file in the Windows Explorer. The 
installation wizard is started.

f) Click Accept to confirm the license agreement.

g) Click Install. A security message opens which informs that the publisher 
of the ExTable.exe cannot be identified.

h) Click Run. The installation process runs.

i) Click Finish. The "Export Table Client" application is installed now.
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Result

The "Export Table Client" application can be started in Windows via Start -> 
All Programs -> Unify -> OpenScape 4000 API Export Table -> Export Table 
client.

Further Processing

Refer to Chapter 4, “Settings”.
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4  Settings

After the installation and licensing, the following settings must be performed:

Section 4.1, „Set the PostgreSQL Database“

Section 4.2, „Creating Users for the Import/Export API (XIE) in the OpenScape 
4000 Assistant/Manager“

Section 4.3, „Setting Database Performance“

Section 4.4, „Establishing Master-Client Synchronization“

Section 4.5, „Testing the Entire System“

Section 4.6, „Providing the Default ID with Password“

Section 4.7, „Assigning User IDs for Switchboard Personnel“

Section 4.9, „Set the Caller Identification“

4.1  Set the PostgreSQL Database

Overview

The configuration settings of the PostgreSQL database must be checked and set 
to monitor connections. The "pgAdmin" administration application is used for this 
purpose.

Procedure

1. Open the "pgAdmin" application via: Start -> All Programs -> PostgreSQL 
<Version> -> pgAdmin III. The "pgAdmin" administration applications is 
started.

2. Select File -> open postgresql.conf. The "Open configuration file" window 
opens.

3. Open the <InstDir>\PSQL\<Version>\data\postgresql.conf file. 
The "Backend Configuration Editor" window opens.

4. Double-click the "listen_adresses" setting. The «Configuration setting 
"listen_adresses"» window opens.

5. Perform in the «Configuration setting "listen_adresses"» window the 
following settings:

• Mark the "Enabled" check box.

• Enter in the "Value" input window:

– If only the connection to the local host shall be accepted: localhost
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– If all connections shall be accepted: *

Click OK. The window is closed and the changed settings are stored.

6. Check if in the "Backend Configuration Editor" window the checkbox nearby 
"listen_addresses" is marked. If not: Mark it, and save the setting.

7. For PostgreSQL 8.2: Stop the PostgreSQL service and restart it:

a) Start -> All Programs -> PostgreSQL <Version> -> Stop service.

b) Start -> All Programs -> PostgreSQL <Version> -> Start service.

This step is not required for PostgreSQL 9.2.

8. Check if a connection to the PostgreSQL database can be established.
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4.2  Creating Users for the Import/Export API (XIE) in the OpenScape 4000 
Assistant/Manager

Overview

To fill and to synchronize the DS-Win database, an new user must be created in 
OpenScape 4000 Assistant/Manager. This user shall have assigned only those 
permissions that DS-Win uses.

Further information to OpenScape 4000 Assistant/Manager you find in: 
OpenScape 4000 Assistant/Manager V8, Access Management.

Prerequisite

The "Import/Export API (XIE)" applications are installed. Refer to Chapter 3.4, 
“Installing "Export Table Client"Application [Import/Export API (XIE)]”.

Procedure

1. Open the OpenScape 4000 Assistant. The OpenScape 4000 Assistant start 
page opens.

2. Select Access Management -> Account Management -> User Account 
Administration in the tree. The "User Account Administration" dialog opens.

3. Creating a new user:

a) Select User -> Add. The "Add new user account" window opens.

b) Enter a new user name in the "New username" field. In OpenScape 4000 
Assistant V6, the user name can only be entered in lower case.

c) Mark the Customer user (cust) radio button in the "Security profile of the 
new user" area.

d) Click OK. The settings are stored.

4. Entering a new password for the user, and setting his policies:

a) Mark the created new user in the "User Account Administration" dialog. 
The policies for this user are displayed.

b) Set the policies as follows:

– In the "Identification" area, no changes are required.

– In the "Actions" area, enter a new password and retype the password. 
Unmark the "Delete password" and "Force password change" 
checkboxes.

– In the "Properties" area, mark the "Password never expires" and 
"Allowed to change password" checkboxes. Unmark the "Lock user 
account" checkbox.
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– In the "Autolock" area, select never for the "Lock account 
automatically" field.

5. Defining a new access right group:

a) Select Access Management -> Account Management -> Access 
Right Configuration in the tree. The "Access Right Configuration" dialog 
opens.

b) Create a new access right group via the "Add New Access Right Group" 
window (e. g. DS-Win).

c) Assign the permissions for Import/Export API (XIE) to this new group. But, 
only allow the access to DISPLAY_NAME, PERS, and PERSDAT.

6. Assign the new access right group to the new user:

a) Select Access Management -> Account Management -> Access 
Right Configuration in the tree. The "Access Right Configuration" dialog 
opens.

b) Mark the new user in the "Access Right Configuration" dialog. The 
"Access Right Groups" for this user are displayed.

c) Right-click the new access right group. A context menu opens.

d) Select the Assign menu item.

Result

The "Import/Export API (XIE)" access right group with the permissions for 
DISPLAY_NAME, PERS , and PERSDAT is assigned to the new user.
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4.3  Setting Database Performance

The database performance is set by the "DS-Win Configuration" application. 
Open this application via Start -> DS-Win V4 -> DS-Win Configuration.

There are two configurable options for loading data from the database into the 
main memory. Possible values include: 
copyDBintoMemory=true or copyDBintoMemory=false (default).

The entire database is loaded into the main memory in this mode. If this mode is 
selected, change the program call to reserve additional main memory.

The default parameters are -Xmx512m -Xms512m. The default call looks as 
follows: 
start "" "%$JAVA%"\bin\javaw.exe -Xmx512m -Xms512m -jar 
DSView.jar

512 MB is reserved in this case. To increase to 1 GB, the line looks as follows: 
start "" "%$JAVA%"\bin\javaw.exe -Xmx1024m -Xms1024m -jar 
DSView.jar

These parameters can be set at the DS-Win installation directory in DSView.bat..
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4.4  Establishing Master-Client Synchronization

4.4.1  Synchronization of a PostGreSQL Database

Overview

The "MCSync.jar" application is used to establish the synchronization between 
two databases, i. e., between the database of the local DS-Win client and the 
database of a remote database server. The synchronization is based on a 
master-client architecture.

The master-client synchronization, which is described here, can be especially 
used in the case of a slow network connection between the DS-Win application 
and the remote database server.

NOTE:  The operating speed of DS-Win can be increased by a local PostGreSQL 
database server.

Example for the «DS-Win Master Client Synchronization» Window

Procedure

Proceed as follows:

1. Double-click the <InstDir>\DS-Win V4\MCSync.jar file. The "DS-Win 
Master Client Synchronisation" window opens.

2. In the "DS-Win Master Client Synchronization" window, enter the following 
data:

• For the master server:

– "Master IP": IP address in the IPv4 format

– "Master Port": port

– "Master User": user name, e. g. postgres

– "Master Password": user password
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• For the local PostGreSQL server (client):

– "Client User": user name, e. g. postgres

– "Database": database schema, e. g. dsw

– "Postgres <install dir>/bin": "bin" folder in the installation folder of the 
PostGreSQL database

3. Click Generate. The DSWin_MCSync.bat file is generated and saved into 
the <Postgres install dir>/bin directory. Confirm the message which 
informs that the file was generated with OK.

This file contains all defined settings and can be started as often as required.

4. Perform the synchronization:

• Either: synchronize manually by executing the DSWin_MCSync.bat file.

• Or: synchronize automatically in defined time intervals by executing the 
DSWin_MCSync.bat file based on a time schedule.

How to define a time schedule is described in the DS-Win V4 
Administration Guide A31003-G6640-M100-3-A9, section 4.5 "Creating 
Time Schedule for Synchronization".

4.4.2  Synchronizing a MySQL Database

The DSWin_MCSync.bat file is located in the 
C:\ProgramData\Siemens\DS-Win V4 installation directory. It can be 
started manually or via "scheduled tasks" (at regular automatic intervals). The file 
stops the SQL server, creates a backup copy in the dataBCKP directory, copies 
the data from the master to the client and starts the SQL server. The user name 
and password for the database must be the same on master and client; the 
remote directory must be shared and attached for copying to take place.
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4.5  Testing the Entire System

Proceed as follows to test the entire system:

Supported Features in the DS-Win Data View Window

• Switching

• Accept incoming calls

• Callback

• Consultation

• Transfer call

• Three-party conference

• Toggling

• Back to waiting subscriber

4.6  Providing the Default ID with Password

In the default system status, the "Administrator" user is listed without password in 
the DSWin and DSWinTest databases.

NOTE:  Important: After installation, you shall provide this user with a password; 
otherwise, the DS-Win Data view can be opened without a password, and data 
can be edited.

Step Action

1 Transfer the data from OpenScape 4000 Manager to the DS-Win master.

2 Synchronize the DS-Win clients.

3 Start AC-Win, or the DS-Win Data view window if AC-Win is not installed. AC-Win starts the DS-Win Data view 
window automatically.

4 Implement the data search according to various criteria.

5 Test automatic dialing of the selected subscriber.
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4.7  Assigning User IDs for Switchboard Personnel

Assign own user IDs with restricted permissions to the switchboard personnel. 
This ensures that the dialog file cannot be modified.

4.8  Entering Completely the Internal Company Number

The internal company number must be given in full to enable correct automatic 
dialing regardless of the location – refer to Chapter 8.3.3, “Digit Analysis”. The 
individual components of the phone numbers must be entered in the application 
settings in a mask provided for this purpose and are then recorded accordingly in 
the configuration DSWin_View_config.xml file. Analysis of tie numbers is only 
taken into account if a site-specific tie number is entered (refer to Chapter 8.3.3.1, 
“Tie Number Analysis”). The following data is required:

• International access code (00 in Germany)

• Local country code (e. g. 49 for Germany, 1 for USA)

• National access code (0 in Germany)

• Area code without the leading zero (e. g. 40 for Hamburg)

• Net code of your system (e. g. 3576)

• Tie number of your system (if any, e. g. 91)

• Trunk access code (e. g. 0)
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4.9  Set the Caller Identification

There are two types of phone numbers that are transferred by AC-Win and DS-
Win, i.e., internal and external numbers. There are two different ways to search 
for these numbers (see dialog below). The "Search field at int.call" option 
contains TieInvertedNumber as default value. This is composed as follows:

TieInvertedNumber= intTieNumber + intExtension.

The "Search field at ext.call" option contains InvertedNumber as default value 
which is composed as follows:

InvertedNumber= intCountry+intAreacode+intNetcode+intExtension.
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DS-Win sends a composite phone number in accordance with the default settings 
and the entries in the data record. Click the Dial properties button. The following 
dialog appears:

If the "Internal" flag is set for one of the numbers in the data record, only the 
"Internal code" field is transferred to AC-Win.

The following logic applies for the tie number in accordance with the settings in 
the data record and under "Dial parameters" in the application settings.

The tie numbers are compared assuming the "Internal code" flag is not set. If the 
numbers differ, the number from the data record is dialed.

Example:

The tie number in the data record of the selected record is 70 at, the tie number 
in the application settings is 27. 70XXXX is dialed in this case and therefore the 
tie number of the data record is used. If the two tie numbers match, only the 
extension is dialed.
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This does not apply only for the tie number, but all access codes ("Country code", 
"Area code", "Net code").

This means: 
The composition of the phone number always depends on the central 
configuration:

• Only the extension is dialed if the data record and the central settings in the 
"Country code", "Area code", and "Net code" fields match.

• The tie number + net code + extension are dialed if the data record and the 
central settings in the Net code field do not match.

• The tie number + national access + country code + net code + extension are 
dialed if the data record and the central settings match neither in the "Country 
code" field nor in the "Net  code" field.



DS-WinSH_ch05.fm

Migration from DS-Win V3 to V4

Starting "Database Migration" Application

A31003-G6640-S100-4-7620, 01/2018
DS-Win V4, Service Manual, Service Manual 41

         

5  Migration from DS-Win V3 to V4

Overview

The Access database of DS-Win V3 can be migrated with the "Database 
Migration" application of DS-Win V4 to a new PostgreSQL, MySQL or MSSQL 
server database. The database data records are copied and reassigned in this 
process.

NOTE:  Important: Not all data records are accepted and assigned properly in 
some cases. Therefore, DS-Win V4 should be newly installed, and the data 
records from the communication systems should be newly imported (apart from 
specific customer databases).

Contents

The migration is performed in the order of the following sections:

Section 5.1, „Starting "Database Migration" Application“

Section 5.2, „Establishing the Connection to the DS-Win V3 Access Database“

Section 5.3, „Establishing the Connection to the Database Server“

Section 5.4, „Performing the Settings“

Section 5.5, „Starting the Migration“

5.1  Starting "Database Migration" Application

Procedure

Select Start -> Programs -> DS-Win V4 -> Database Migration. The "DS-Win 
Database migration" window opens.

Further Processing

Refer to Section 5.2, „Establishing the Connection to the DS-Win V3 Access 
Database“.
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5.2  Establishing the Connection to the DS-Win V3 Access Database

Overview

A connection must be established to the Access database to readout their data.

Procedure

Proceed as follows:

1. In the "DS-Win Database migration" window under "Step 1 – Connect to the 
old Access database", click Connection. The "Connect to an Access 
database" window opens.

2. In the "Connect to an Access database" window, click Browse, and select the 
Access database which you want to migrate. The path is entered into the 
"Database path" field.

3. In the "Connect to an Access database" window, click Connect. A message 
is displayed which informs you that the connection to the database was 
established. In addition, you are advised that all connections to the Access 
database must be closed before the migration.

4. Confirm with OK, and click Close. The database path is entered under "Step 
1 – ...".

Further Processing

Refer to Section 5.3, „Establishing the Connection to the Database Server“.
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5.3  Establishing the Connection to the Database Server

Overview

A connection must be established to the new database server where the data 
records shall be imported into the database.

Procedure

Proceed as follows:

1. In the "DS-Win Database migration" window under "Step 2 – Connect to a 
database server", click Connection. The "Connect to a database server" 
window opens.

2. Perform the following settings in the "Connect to a database server" window:

• "Database server": e. g. PostGreSQL

• "Host name or IP": e. g. localhost

• "Port number": e. g. 5432

• "User name": e. g. postgres

• "Password": e. g. postgres

3. Click Connect in the "Connect to a database server" window. A message is 
displayed which informs that the connection to the database was established.

4. Confirm with OK, and click Close. The database server path is entered under 
"Step 2 – ...".

Further Processing

Refer to Section 5.4, „Performing the Settings“.
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5.4  Performing the Settings

Overview

In this section, the properties of the new database and the migration mode must 
be selected.

Procedure

Proceed as follows:

1. In the "DS-Win Database migration" window under "Step 3 – Migration 
settings", click Settings. The "Settings" window opens.

2. Perform the following settings in the "Settings" window:

"Database properties":

• "Database name": e. g. dsw

• "Schema name": e. g. dsw

If the connection shall be established to a PostgreSQL server, you can 
enter a "Schema name". The schema name must be explicitly written in 
lower case. If no schema name is entered, the new table is created in the 
predefined "public" schema.

NOTE:  Important: Do not use a Schema name which already exists. If you 
already use a dsw schema, e. g., in your database, it must be deleted or renamed.

"Migration mode":

Select between:

• "Only database structure"

• "Database structure and data"

Click OK. The settings are entered under "Step 3 – ...".

Further Processing

Refer to Section 5.5, „Starting the Migration“.
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5.5  Starting the Migration

Overview

In this section, the contents of the Access database is copied into the 
PostgreSQL database.

Procedure

Proceed as follows:

1. Click Start. The copy process starts and messages of the program are 
displayed.

2. Wait until the copy process is finished. A message opens indicating that the 
database migration was successful.

NOTE:  Important: The migration process depends on the size of the Access 
database, and may take long. The application doesn’t respond during this time.

Result

The "Database Migration" application of DS-Win V4 creates a script file from the 
tables, indices and data (if selected) which is executed on the connected server. 
Structures and data (if selected) are thereby created on the server.
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6  HiMed Connection to DS-Win

Additional Information

NOTE:  Additional and more detailed information, which exceeds this chapter, 
you can find in the HiMed Service Manual J31032-K2004-U110-A2-**19, chapter 
23 "ODBC-Connection".

Contents

You find the following topics in this chapter:

Section 6.1, „Configuring and Installing DS-Win V4 on HiMed Server and HiMed 
Client“

Section 6.2, „Creating an Informix Database for DS-Win“

Section 6.3, „Starting DS-Win Administration“

Section 6.4, „Creating the Database Configuration“

Section 6.5, „Activating the Informix Database“

Section 6.6, „Establishing a Database Connection for the GUI Designer“

Section 6.7, „Set the DS-Win User Interface“

Section 6.8, „Setting up the «Search for subscribers» Worksheet in 
GUI Designer“

Section 6.9, „Creating Layouts“

Section 6.10, „Special Cases“
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6.1  Configuring and Installing DS-Win V4 on HiMed Server and HiMed 
Client

Overview

DS-Win V4 must be installed on the HiMed server and on the HiMed client. The 
standard installation of the Informix component on the client is required.

Procedure

Proceed as follows:

1. Perform the standard installation of the Informix component on the HiMed 
client. Refer to J31032-K2004-U110-A2-**19, HiMed Service Manual -> 
"Client" chapter.

2. Start the \opt\himed\dswin\dswin_V4.sh script on the HiMed server. 
The script creates an "informix" schema in the HiMed database with the 
required database objects.

3. Install and license the DS-Win V4 on the HiMed client; refer to Chapter 3.1, 
“Installation and Licensing of DS-Win V4”.

4. Configure the SNMP traps; refer to Chapter 3.2, “Installing, Activating, and 
Configuring SNMP Traps”.

5. Create an himed_informix.xml Informix database connection; refer also 
to Section 6.6.3, „Establishing the Database Connection“.
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6.2  Creating an Informix Database for DS-Win

Overview

Based on Windows, all commands must be executed in the console of the IBM 
Informix Dynamic Server. The database applications you find in the bin directory.

The ondblog.exe and ontape.exe commands are used to change the database 
buffer mode and to backup the database. These commands are required for the 
JDBC (Java Data Base Connectivity) database interface to execute all SQL 
queries.

Based on Windows: Creating the Informix Database

Based on Windows, proceed as follows to create an Informix database which is 
compliant to DS-Win:

Based on Windows, the tape recorder for the "ontape" command in the 
ONCONFIG file can be set; the parameter then is "TAPEDEV STDIO".

Step Action

1 Enter the following command to create an Informix SQL database: 
dbaccess.exe - createdb_informix.sql. In the createdb_informix.sql script, the dsw database 
name must be defined. The database is created now.

2 Enter the following command to set the buffered logging for the database: ondblog.exe buf dsw
The buffered logging is set and the database is locked now.

3 Enter the following command to set the buffered logging and to unlock the database:  
ontape.exe -s -L 0 >C:\tmp\ifxdsw.bkp
The buffered logging was set. A level 0 backup is performed now and a C:\tmp\ifxdsw.bkp backup file is 
created now. 
The database is unlocked now.

4 Delete the C:\tmp\ifxdsw.bkp backup file, which was used to unlock the dsw database.
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Based on Linux: Creating the Informix Database

Based on Linux, proceed as follows to create an Informix database which is 
compliant to DS-Win:

Further Processing

Continue with Section 6.4, „Creating the Database Configuration“.

Step Action

1 Enter the following command to create an Informix SQL database: 
dbaccess - createdb_informix.sql. In the createdb_informix.sql script, the dsw database name 
must be defined. 
The database is created now.

2 Enter the following command to set the buffered logging for the database: ondblog buf dsw
The buffered logging is set and the database is locked now.

3 Enter the following command to set the buffered logging and to unlock the database:  
ontape -s -L 0 -t STDIO >/tmp/ifxdsw.bkp
The buffered logging is set now. A level 0 backup was performed and a >/tmp/ifxdsw.bkp backup file is 
created now. The database is unlocked now.

4 Delete the >/tmp/ifxdsw.bkp backup file, which was used to unlock the dsw database.
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6.3  Starting DS-Win Administration

Ways of Starting

There are two ways of starting the "DS-Win Administration" application with the 
standard dialog:

• Double-click the relevant dialog file.

• Start the "DS-Win Administration" window via the Windows Start menu.

Starting via the Windows Start menu 

Proceed as follows:

NOTE:  The only user ID available by default for using the DS-Win Administration window 

is the "Administrator" user ID. Initially, this works without a password. We strongly 

recommend that you set a password for this user ID as soon as you log in for the first time. 

Once a password is set, a login dialog pops up each time you open the DS-Win data view 

window. It is a good idea to set up additional user IDs with lower privileges.

"DS-Win Administration" window

Step Action

1 Select Start -> Programs -> DS-Win V4 -> DS-Win Admin. The "DS-Win password" logon window opens.

2 Enter the user name and the password into the logon window. Then click OK. The "DS-Win Administration" 
window opens.
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The "DS-Win Administration" window is used for administering a DS-Win 
database. It offers the following functions:

• edit data

• import or export data

• create new databases

• edit table structures

• create new tables

• create layouts

• perform synchronizations with host databases

• administer users

• set countries

• change passwords

You can save the changed database or language settings using File -> Save file. 
The administration window is started with these new values the next time it is 
opened.

The "Tables" tab offers mapping tables. The "Print formats" tab offers print 
formats.
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6.4  Creating the Database Configuration

Prerequisite

The DS-Win Administration was started. Refer to Section 6.3, „Starting DS-Win 
Administration“.

Example for the «Edit database config file» Window

Procedure

Proceed as follows:

Step Action

1 In the "DS-Win Administration" window, select Database -> Close database to close the open database. The 
database is closed.

2 Select Database -> Open database to open the Informix database. The "Open new DB schema" window 
opens.

3 Mark the hibernate_Informix.xml configuration file in the "Open new DB schema" window, and click 
Open. The "Edit database config file" window opens.

4 Perform the following settings in the "Edit database config file" window:

1. In the "Database" drop-down menu, select the Informix entry. A default path is automatically 
entered in the "URL" input field.

2. Change the default path as described in the "Default Path in the «Edit database config file» 
Window" section.

3. Enter the user name and the password.

5 To test the connection to the Informix database, click Test connection. If your settings are correct, the 
following message is displayed: Connection is ok.

If the connection doesn’t work: Check your settings in the "Edit database config file" window, and 
correct it.

6 If the connection works: Click Save in the "Edit database config file" window to save the database configuration 
settings.
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Default Path in the «Edit database config file» Window

After selection of Informix in the "Database" drop-down menu, a default path is 
automatically entered which you must adapt. This default path, e. g., is as follows:  
jdbc:informix-sqli://127.0.0.1:9088/
dsw:INFORMIXSERVER=ol_ids_1150_1.

Further Processing

Continue with Section 6.5, „Activating the Informix Database“.

Part of the default path Description

127.0.0.1:9088 Server IP address which is used by Informix; in the SERVER-IP:PORT format

dsw Name of the DS-Win database which was set in the createdb_informix.sql 
script.

ol_ids_1150_1 Name of the Informix server
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6.5  Activating the Informix Database

Prerequisites

• The DS-Win Administration was started. Refer to Section 6.3, „Starting DS-
Win Administration“.

• The database was configured. Refer to Section 6.4, „Creating the Database 
Configuration“.

Procedure

Proceed as follows:

Result

The Informix database is now activated for DS-Win.

Further Processing

Continue with Section 6.6, „Establishing a Database Connection for the GUI 
Designer“.

Step Action

1 If a database was automatically opened: Select Database -> Close database in the "DS-Win Administration" 
window. The database is closed.

2 Select Database -> Open database to open the Informix database. The "Open new DB schema" window 
opens.

3 Mark the hibernate_Informix.xml configuration file in the "Open new DB schema" window, and click Open. 
The "DS-Win password" window opens.

4 Enter the user name and the password, and click OK. The Informix database opens.
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6.6  Establishing a Database Connection for the GUI Designer

Overview

You can optimally adapt the database and the user interface of DS-Win to the 
user’s requirements by the GUI Designer. To do so, you must establish the 
connection to the Informix database of HiMed beforehand.

In this section, only those operating steps and control elements are described 
which are required to establish the HiMed/Informix database connection. More 
detailed information to the GUI Designer you find in: A31003-G6640-U101-*-**19, 
DS-Win V4, GUI Designer, User’s Guide -> section 2.3 "Creating an Example 
Application".

Contents

You find the following topics in this section:

Section 6.6.1, „Opening the Data Resource Manager“

Section 6.6.2, „Set the Database Driver“

Section 6.6.3, „Establishing the Database Connection“

Section 6.6.4, „Set the Data Source“

6.6.1  Opening the Data Resource Manager

Procedure

Proceed as follows:

Step Action

1 Start the GUI Designer via Start -> Programs -> DS-Win V4 -> GUI Designer. The GUI Designer opens with 
an empty worksheet.

2 Open the designer_<en>_Informix.xml file via File -> Open. The Informix database table opens.

3 Open the Data Resource Manager via Database -> Configure. The Data Resource Manager opens with the 
"Database Driver", "Database Connections", and "Data Sources" tabs.
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6.6.2  Set the Database Driver

NOTE:  Important: The settings described in this section are examples and must 
be adapted to your requirements.

Prerequisite

The Data Resource Manager is open; refer to Section 6.6.1, „Opening the Data 
Resource Manager“.

Example for the Data Resource Manager with the «Database Drivers» Tab

Procedure

Proceed as follows:

Step Action

1 In the Data Resource Manager, select the Database Drivers tab.

2 Select the HiMed-Driver entry in the "Driver name" drop-down menu.

3 Under "Driver properties" perform the following settings:
• "Def.URL": Path to the database. You find explanations for this in the "«Def.URL» Input Field on the 

«Database Drivers» Tab" section.
• "Jar/Zip file": Path to the driver file 

<InstDir>\DS-Win V4\data\drivers\ifxjdbc.jar
• "Java Class": com.informix.jdbc.lfxDriver
• "Dialect": Informix
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«Def.URL» Input Field on the «Database Drivers» Tab

The default path must be adapted as follows (example):  
jdbc:informix-sqli://himed:1536/
himed:INFORMIXSERVER=himeddb; 
DB_LOCALE=en_us.utf8;CLIENT_LOCALE=en_us.utf8

Further Processing

Continue with Section 6.6.3, „Establishing the Database Connection“.

Part of the default path Description

himed:1536 Server IP address (or server name) which is used by Informix; in the SERVER-
IP (or SERVERNAME:PORT) format

himed HiMed database name

himeddb Informix/HiMed server name

DB_LOCALE=en_us.utf8; Definition of the language and the character encoding for the server’s database

CLIENT_LOCALE=en_us.utf8 Definition of the language and the character encoding for the client’s database
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6.6.3  Establishing the Database Connection

NOTE:  Important: The settings described in this section are examples and must 
be adapted to your requirements.

Prerequisite

The Data Resource Manager is open; refer to Section 6.6.1, „Opening the Data 
Resource Manager“.

Example for the Data Resource Manager with the «Database Connections» 
Tab

Procedure

Proceed as follows:

Step Action

1 In the Data Resource Manager, select the Database Connections tab.

2 Select the Informix or HiMed-Connection entry in the "Connection name" drop-down menu.

3 Under "Connection properties", perform the following settings:
• "Driver": HiMed-Driver
• "URL": Path to the database. After clicking "Pattern", a default path is entered which must be changed. You 

find explanations for this in the "«URL» Input Field on the «Database Connections» Tab" section.
• "User": User’s name, e. g. odbc32
• "Password": User’s password

4 To check the connection to the Informix database, click Test. If your settings are correct, the following message 
is displayed: Connection is ok.

If the connection dosn’t work: Check the settings, correct and test again.
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«URL» Input Field on the «Database Connections» Tab

The default path must be adapted as follows (example):  
jdbc:informix-sqli://himed:1536/
himed:INFORMIXSERVER=himeddb; 
DB_LOCALE=en_us.utf8;CLIENT_LOCALE=en_us.utf8

Further Processing

Continue with Section 6.6.4, „Set the Data Source“.

Part of the default path Description

himed:1536 Server IP address (or server name) which is used by Informix; in the SERVER-
IP (oder SERVERNAME:PORT) format

himed Name of the HiMed database

himeddb Name of the Informix/HiMed server

DB_LOCALE=en_us.utf8; Definition of the language and the character encoding for the server’s database

CLIENT_LOCALE=en_us.utf8 Definition of the language and the character encoding for the client’s database
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6.6.4  Set the Data Source

NOTE:  Important: The settings described in this section are examples and must 
be adapted to your requirements.

Prerequisite

The Data Resource Manager is open; refer to Section 6.6.1, „Opening the Data 
Resource Manager“.

Example for the Data Resource Manager with the «Data Sources»Tab

Procedure

Proceed as follows:

Further Processing

Continue with Section 6.7, „Set the DS-Win User Interface“.

Step Action

1 In the Data Resource Manager, select the Data Sources tab.

2 Select the HiMed-Datasource entry in the "Data Sources" drop-down menu.

3 Under "Data Source properties", perform the following settings:
• "Connection": HiMed-Connection
• "Table": ds_win

4 Click Apply to activate your settings.

5 Click Quit to close the Data Resource Manager.
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6.7  Set the DS-Win User Interface

Prerequisite

The database connection was set; refer to Section 6.6.3, „Establishing the 
Database Connection“.

Procedure

Proceed as follows:

Step Action

1 Start the DS-Win Configuration via Start -> Programs -> DS-Win V4 -> DS-Win Configuration. The DS-Win 
Configuration opens.

2 In the "License server and SNMP settings" window, select the GUI tab.

3 Perform the following settings in the GUI tab:
• In the "Default GUI file" drop-down menu: designer_<en>_Informix.xml.
• In the "Load the whole Subscriber table from the database into the memory" drop-down menu: No

4 Click Save to save the configuration settings. The user interface is set, and DS-Win can be started.

5 Click Close to leave the window.
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6.8  Setting up the «Search for subscribers» Worksheet in GUI Designer

Overview

Using the GUI Designer, you can optimally adapt the database and the user 
interface of DS-Win to the user’s requirements. Refer also to: 
A31003-G6640-U101-*-**19, DS-Win V4, GUI Designer, User’s Guide.

Prerequisite

The data source, i. e., the "ds_win" table was set; refer to Section 6.6.4, „Set the 
Data Source“.

Contents

You find the following topics in this section:

Section 6.8.1, „Starting the GUI Designer“

Section 6.8.2, „Structure of the «ds_win» Table“

Section 6.8.3, „Available Indices“

6.8.1  Starting the GUI Designer

Procedure

Proceed as follows:

Step Action

1 Start the GUI Designer via Start -> Programs -> DS-Win V4 -> GUI Designer. The GUI Designer is opened 
with an empty worksheet.

2 Set the "Search for subscribers" worksheet as described in: A31003-G6640-U101-*-**19, DS-Win V4, GUI 
Designer, User’s Guide -> section «2.5 Setting up the "Search for subscribers" Worksheet».
For HiMed, consider the following sections:
• Section 6.8.2, „Structure of the «ds_win» Table“
• Section 6.8.3, „Available Indices“
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6.8.2  Structure of the «ds_win» Table

The "ds_win" table is designed as follows:

Field Meaning Data type

fallnummer Participant’s case name, consecutive INT

nachname Participant’s last name CHAR(30)

vorname Participant’s first name CHAR(30)

p_nummer Personnel/patient number CHAR(20)

aufnahmetag Day of admission DATE

abgerechnet Was an invoice already generated? (0=no, 1=yes) SMALLINT

userclass_id Number of the user class INT

userclass_txt Name of the user class CHAR(30)

group_id Number of the user group INT

group_txt Name of the user group CHAR(15)

tarifmodell Number of the tariff model INT

kontostand Account balance of the participant (regardless of the deposit) MONEY(16,2)

guthaben Credit of the participant (in consideration of the deposit) MONEY(16,2)

status_id Number of the current status SMALLINT

status_txt Name of the current status CHAR(20)

status_seit Date/time of the last status change DATETIME

pin PIN CHAR(12)

medien_id Number of the medium (e. g. chip card number) CHAR(20)

zimmer Room number CHAR(10)

gruppe Group (e. g. ward) CHAR(10)

telefon Technical phone number of the participant CHAR(10)

uc_name Last name and first name, divided by space characters. This field can be 
used as search item. It is assigned to the "nachname" field.

CHAR(61)

anmerkung Comment CHAR(128)

tel_antrag Request for the phone service: "y"=yes or "n"=no CHAR(2)

sprache_id Code of the participant’s language INTEGER

sprache_iso_txt ISO abbreviation of the language CHAR(5)

strasse Street CHAR(30)

plz Postal code CHAR(7)

ort City CHAR(30)

Table 1 "ds_win" table
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6.8.3  Available Indices

The following indices are available for the assigned fields. These indices can be 
used in the particular dialogs:

Index Field Index type

ds_win_ix1 nachname Normal

ds_win_ix2 uc_name Normal

ds_win_ix3 p_nummer Normal

ds_win_ix4 medien_id Normal

ds_win_ix5 zimmer Normal

ds_win_ix6 telefon Normal

ds_win_ix7 vorname Normal

ds_win_ix8 userclass_txt Normal

ds_win_ix9 ort Normal

ds_win_ix10 userclass_txt, vorname Combined

ds_win_ix11 userclass_txt, medien_id Combined

ds_win_ix12 userclass_txt, zimmer Combined

ds_win_ix13 userclass_txt, telefon Combined

ds_win_ix14 userclass_txt, uc_name Combined

ds_win_ix15 userclass_txt, nachname Combined

ds_win_ix16 userclass_txt, ort Combined

ds_win_ix17 uc_name Normal, with inverted sort sequence

ds_win_ix18 group_txt Normal

ds_win_ix19 userclass_txt, group_txt Combined

Table 2 Indices for the assigned fields
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6.9  Creating Layouts

How to create layouts is described in: A31003-G6640-M100-3-**A9, DS-Win V4, 
Administration Guide -> section 3.4 "Creating Layouts".

A maximum number of 5 layouts can be created. Consider minimizing the file size 
of each layout (e. g. reduce the graphics).

6.10  Special Cases

Sometimes, the customer doesn’t want to create additional data tables in the 
Informix database which are absolutely required for DS-Win. In these cases, DS-
Win can be set to use, e. g., the provided PostgreSQL database to store the 
required data tables. As a result, an already existing data table can be used as 
data source for DS-Win. A normal DS-Win installation with a PostgreSQL 
database is required here. A special user interface must then be created by the 
GUI Designer.

The procedure is described in:

Chapter 3, “Installation and Licensing”

Chapter 6, “HiMed Connection to DS-Win”
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7  DS-Win Client Installation Without an Own PostGreSQL 
Database

Overview

It may be required that the DS-Win client to be installed must access an already 
existing PostGreSQL database on the host PC. For this, the DS-Win Client must 
be completely installed. The installation of the PostGreSQL database is skipped 
in this process. Afterwards, the address of the PostGreSQL database must be 
entered into the configuration xml files.

Contents

You find the following topics in this chapter:

Section 7.1, „Installing the DS-Win Client“

Section 7.2, „Performing Settings on the Host PC“

Section 7.3, „Performing Settings on the Client PC“

Section 7.4, „Testing the Connection“

7.1  Installing the DS-Win Client

Procedure

Install the DS-Win Client. This procedure is described in: Chapter 3, “Installation 
and Licensing”. Skip the installation of the default database in this process (here: 
PostGreSQL).

Further Processing

Continue with Section 7.2, „Performing Settings on the Host PC“.
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7.2  Performing Settings on the Host PC

Overview

Configure the firewall on the host PC and enter the address of the client PC into 
the pg_hba.conf configuration file to ensure the client PC can access to the 
PostGreSQL database on the host PC.

Procedure

Proceed as follows:

1. Deactivate the Windows firewall, or set it to "trusted".

2. Open the C:\PSQL\9.2\data\pg_hba.conf file with an editor (e. g. 
Notepad++).

3. Proceed as follows in the pg_hba.conf file:

a) Search the entry:

b) Add the following lines to this entry:

The 1.69.31.3/32 item is an example of address and port of the client 
PC. Adapt this item to your requirements.

4. Save and close the pg_hba.conf file.

Further Processing

Continue with Section 7.3, „Performing Settings on the Client PC“.

#TYPEDATABASEUSERADDRESSMETHOD

#IPv4 local connections:

hostallall127.0.0.1/32md5

hostallall0.0.0.0/0md5

hostdswpostgres1.69.31.3/32trust
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7.3  Performing Settings on the Client PC

Overview

On the client PC, the direction to the host PC’s PostGreSQL database must be 
defined. To do so, the settings in the DBConnections.xml and 
hibernate.PostgreSql.cfg.xml files must be performed.

Modifying the «DBConnections.xml» File

Proceed as follows:

1. Open the <InstDir>\DS-Win V4\Data\DBDesc\DBConnections.xml 
file with an editor (e. g. Notepad++).

2. Proceed as follows in the DBConnections.xml file:

a) Search the entry:

b) Modify the entry as follows:

The 1.69.31.11:5432 item is an example of address and port of the 
host PC. Adapt this item to your requirements.

3. Save and close the DBConnections.xml file.

<DBConnection name="pg">

<driver>postGreSQL</driver>

<url>jdbc:postgresql://localhost:5432/dsw?schema=dsw</url>

<user>postgres</user>

<pwd>postgres</pwd>

<DBConnection name="pg">

<driver>postGreSQL</driver>

<url>jdbc:postgresql://1.69.31.11:5432/dsw?schema=dsw</url>

<user>postgres</user>

<pwd>postgres</pwd>
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Modifying the «hibernate.PostgreSql.cfg.xml» File

Proceed as follows:

1. Open the 
C:\DSWinV4\Config\Hibernate\hibernate.PostgreSql.cfg.xml 
file with an editor (e. g. Notepad++).

2. Proceed as follow in the hibernate.PostgreSql.cfg.xml file:

a) Search the entry:

b) Modify the entry as follows:

The 1.69.31.11:5432 item is an example of address and port of the 
host PC. Adapt this item to your requirements.

3. Save and close the hibernate.PostgreSql.cfg.xml file.

<hibernate-configuration>

<session-factory>

...

<property name="connection.url">jdbc:postgresql://localhost:5432/dsw?schema=dsw</
property>

<hibernate-configuration>

<session-factory>

...

<property name="connection.url">jdbc:postgresql://1.69.31.11:5432/
dsw?schema=dsw</property>
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7.4  Testing the Connection

Proceed as follows:

1. Start the DS-Win Administration:

a) Select Start -> Programme -> DS-Win V4 -> DS-Win Admin. The "DS-
Win password" login window opens.

b) Enter user name and password into the login window. Then click OK. The 
"DS-Win Administration" window opens.

2. If a database was automatically opened: Select Database -> Close 
database in the "DS-Win Administration" window. The database is closed.

3. Select to open the PostGreSQL database of the host PC: Database -> Open 
database. The "Open new DB schema" window opens.

4. Mark the hibernate.PostgreSql.cfg.xml configuration file in the 
"Open new DB schema" window, and click Open. The "DS-Win password" 
window opens.

5. Enter user name and password, and click OK. The PostGreSQL database on 
the host PC opens.

6. Start the "DS View" application via Start -> Programs -> DS-Win V4 -> 
DS-Win. The data of the PostGreSQL database are displayed.
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8  Hints, Troubleshooting and Restrictions

This chapter provides important information on using DS-Win V4.

8.1  DS-Win and AC-Win

8.1.1  Starting DS-Win and AC-Win Automatically

DS-Win V4 can be started automatically via AC-Win.

If AC-Win DS-Win does not start automatically, the "LaunchApp" parameter must 
be deleted in the registry under HKLM/Software/Unify/ACWin/IP/Container/
Settings.

NOTE:  Important: Do not place both programs in the Startup folder; interaction 
between the two programs results in program errors!

If the DS-Win database shall be automatically synchronized with the database of 
a master PC immediately after login, the DSWin_MCSync.bat script must be 
entered in the startup group.
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8.1.2  Interworking with AC-Win

Incoming Calls

If you answer a call in AC-Win but are using DS-Win when another call is 
incoming, AC-Win will not activate automatically:

• Keyboard input continues to be processed by DS-Win. 

• You must switch manually to AC-Win, either by clicking the AC-Win window, 
or the icon in the task bar.

Incoming calls with Active Partition

• An entry in the list box at the top right in the Control Panel ("Berlin" in this 
case) indicates that the partition is active. In other words, only data records 
that have the appropriate entry in the "Subscriber" table in the "Partition" field 
are displayed.

• If an incoming call is answered in AC-Win when DS-Win Data view is in speed 
search mode and the partition is active, the entry is automatically removed 
from the list box. The entire table is searched for the calling subscriber if the 
caller is not found in the active partition.

Minimizing DS-Win V4 Data view

When DS-Win Data view is reduced to icon size, the window is not restored to the 
foreground when input is made in AC-Win.  
To restore DS-Win Data view to the foreground after it has been reduced to icon 
size, click the program in the task bar.



DS-WinSH_ch08.fm

Hints, Troubleshooting and Restrictions

Synchronization

A31003-G6640-S100-4-7620, 01/2018
DS-Win V4, Service Manual, Service Manual 75

         

8.2  Synchronization

8.2.1  Designing the Table Structure

In the DS-Win Administration under Tables -> Design in the "Design table" 
dialog, a new line can be inserted into the table by pressing the tabulator in the 
last field of the last row.

8.2.2  Indices in the Subscriber Table

The following indices are defined in the "Subscriber" table:

Index name Fields

@Address Address

@Building Building

@Company Company

@FaxExtension FaxExtension

@IntExtension IntExtension

@InvertedNumber InvertedNumber

@LastName LastName

@MasterID MasterID, MasterSource

@Organization Organization, Sortname

@Partition Partition

@PartitionBuilding Partition, Building

@PartitionFaxExtension Partition, FaxExtension

@PartitionIntExtension Partition, IntExtension

@PartitionOrganization Partition, Organization, Sortname

@PartitionRoom Partition, Room, Building

@PartitionSortname Partition, Sortname, Organization

@PartitionText1 Partition, Text1, Sortname, Organization

@Room Room, Building

@SecretaryID SecretaryID

@Sortname Sortname, Organization

@SubscriberID SubscriberID

@Text1 Text1, Sortname, Organization

@TieInvertedNumber TieInvertedNumber

PrimaryKey SubscriberID
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8.2.3  Configuring the Partition Functionality

If the "partition functionality" is not used, the indices in the subscriber table that 
start with @Partition should be removed to reduce the size of the database.

If the "partition functionality" is to be used and non-default fields are to be 
displayed for speed search, the relevant composite indices must be inserted into 
the subscriber table in question:

NOTE:  Blank rows are to be inserted one at a time above the marked line (➜) 
(Insert row). Each row should be filled out before a new row is added and so on. 
If more than one row is added at a time, the index sequence may get mixed up in 
the case of composite indices.

Index name Fields

@PartitionFeldname Partition

@PartitionFeldname Feld name
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8.3  Notes on Data View

8.3.1  Database Names in DS-Win Data View

When creating a new database reference under "Database adjustment", the 
database name that you wish to assign should correspond to the alias name. This 
will prevent confusion later when creating dialogs.

8.3.2  «Partition» Field

In the standard dialog, the combination box in the top right corner corresponds to 
the Partition field in the database.

8.3.3  Digit Analysis

8.3.3.1  Tie Number Analysis

Tie number analysis (i.e. dialing the tie number digit entered in the subscriber 
record) is performed only if a tie number was configured for the local HiPath 4000 
PBX:  
This can be implemented in DS-Win Data view in the menu Options -> 
Application settings -> Tie number.

If a tie number is contained in the subscriber data record, but no tie number is not 
configured under "Application settings", the tie number in the subscriber data 
record is ignored for automatic connection setup.

8.3.3.2  Field »Internal code« IntInternal (AltInternal, 
MobInternal, FaxInternal)

If the IntInternal field contains the value True for the data record to be 
dialed, and if the option Use internal flag is activated in the "Dial Properties" 
dialog, only the IntExtension field is taken into account for dialing, i. e., only 
the extension is dialed in each case.  The same applies for the fields 
AltInternal, MobInternal and FaxInternal.
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8.3.4  Dialog File

8.3.4.1  Saving the Dialog File

After installation, the dialog file supplied as standard and adapted to the 
customer’s wishes shall also be saved in another directory, or under a different 
name. Thus, it can be accessed again quickly should any problems arise. When 
editing a dialog, you should save regularly.

8.3.5  Note on Sorting by Clicking on the Column Title

If the sorting is changed by clicking on the particular column title, the field 
contents of the marked data record are transferred completely to the associated 
search field. This can, however, be made up of several fields. If this is the case 
and a search is now made in "Result Search" mode with the transferred field 
contents, you will not obtain any hits as a search can only be made for a single 
field. The corresponding partial string must be deleted first (e.g. in the case of 
"Mayer Bernard Dr.", "Dr." must be removed).

8.3.6  Data Display in the Output Table (DataGrid)

Data records cannot be modified/configured/deleted in output tables (DataGrid).

If a field in the output table (e. g., on the tab "Search for subscribers") is shorter 
than the data record information to be displayed, the contents of this field are only 
shown until the first space. 

If the entire content is to be displayed, you must either extend the column width 
or adjust the row height until the data is shown in its entirety.

Example:

In this case the department information is not displayed in full:

Either extend the column width,

or double the row height:
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8.3.7  Displaying the Default Window in "Small fonts" 
Only

With a screen resolution of 1024 x 768 pixels, small fonts must be used to display 
the supplied default dialogs correctly (Control Panel -> Display -> „less - 100% 
Standard).

8.3.8  Printing Data

8.3.8.1  Notes on «Printing the Phone Book»

If you want to print phone books using DS-Win Data view, note the following 
points:

• Only data from the table with the structure "Subscriber Table" can be printed.

• In the case of a result search, all the data records found will be printed in 
exactly the same order, and sorted in exactly the same way as they appear 
on the screen. The sorting sequence can be altered by adjusting the column 
sequence.

• In the case of a speed search, all data records are printed in the displayed 
order and sorting sequence, regardless whether a partition is activated 
(combination box at the top right displays text).

• An individual data record can only be printed with the speed search.

8.3.8.2  Printing the Result Search

If you wish to print a phone book which does not have the name as the primary 
sort criteria (e. g. according to department), proceed as follows:

• In the result search, move the column with the primary sort criteria to the start 
(left). To do this, click the corresponding title and hold down the mouse 
button.

• Move the title to the required position and release the mouse button.



Hints, Troubleshooting and Restrictions

DS-WinSH_ch08.fm

Notes on Data View

 A31003-G6640-S100-4-7620, 01/2018
80 DS-Win V4, Service Manual, Service Manual

        

Once the required search criteria is entered and a new search initiated, the 
hits are sorted in accordance with the column sequence (from left to right).

• The "Add" and "New" functions are not available for a data record in Result 
search mode.

NOTE:  If the search string " * " is used, only those hits are shown where an entry 
is available in the corresponding field. Unlike other databases, a hit is not regis-
tered if the field is empty in the data record. 
 
To ensure that all data records are found, select a field that always contains an 
entry (e.g.  name). 
Alternatively, make sure that when entering new data records, at least one blank 
is entered in the particular data record field.

• The Print mode record is only available in Speed search mode.
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8.4  Presence Management

NOTE:  The computer has to be restarted after parameters have been set.

8.4.1  Outlook

The first time you log in, you will be prompted for an Outlook profile. The profile 
will then be saved in the DSWin_view_config.xml file and used for subsequent 
logins. The security options should be set in the case of this profile to "approved" 
rather then "prompt". See also the Outlook Security Seite and Section 8.4.2.1, 
„Performing Changes on the Exchange Server“ for further information. The profile 
can be used both in "Cached" and "Uncached" mode. While the data update is 
faster in "Uncached" mode, this mode requires you to log in again periodically to 
determine the current "Free" and "Busy" status.

See also "Outlook reopen period" in the Application settings (default is 5 minutes) 
and Section 8.4.3.2, „Setting Free/Busy Options“.

The login is either the eMail address or the user name of the Outlook user. Use 
of the eMail address is recommended as it is clearer.

8.4.1.1  Reinstalling Collaboration Data Objects (CDO.dll)

Carry out the following steps:

1. Launch the "Add/Remove Programs" dialog with 
Start -> Settings -> Control Panel -> Add or Remove Programs.

2. Select "Microsoft Office" (e. g. Microsoft Office Professional Edition 2003) and 
click Change. The "Maintenance Mode Options" window with the "Add or 
Remove Features", "Reinstall or Repair" and "Uninstall" buttons will appear.

3. Select Add or Remove Features and click Next. The "Custom installation" 
dialog will appear.

4. Select Advanced customization of applications and click Next. The 
"Advanced Customization" dialog will appear.

5. Choose Microsoft Office -> Microsoft Outlook for Windows -> 
Collaboration Data Objects -> Start from desktop.

6. Click Update. The Collaboration Data Objects will be reinstalled.

SH_CA-GW_04.fm
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8.4.2  Adapting Outlook Security Settings

The "SR1 update: Extended E-Mail Security" for Outlook 2000 from Microsoft 
contains additional security functions for Outlook. Once this update has been 
installed, Outlook issues warning messages on the interface if an application tries 
to access eMails or contact folders in Outlook.

Because DS-Win performs such access as part of its functionality, warnings 
continuously appear when groupware is active. This is naturally irritating because 
Microsoft only gives users the possibility of having access enabled for at most ten 
minutes. To resolve such problems, Microsoft has provided an option for 
modifying the Outlook security settings. The following restrictions apply however:

• Outlook is operated with Exchange Server

• The user uses a profile, which routes incoming eMails to the Exchange 
mailbox or to an offline folder (.ost file). Two modifications are required in 
order to change the security settings:

– The administrator has to create a specific public folder on the Exchange 
server and publish a specific Outlook form. See Section 8.4.2.1, 
„Performing Changes on the Exchange Server“.

– A specific registry key has to be set on the client for every user. See 
Section 8.4.2.2, „Performing Changes on the Outlook Host“.

If Outlook is being operated with system policies, this step is replaced by 
modifying the policies on the Exchange server. Details of this can be found under 
the Internet link above. The prepared Outlook form (Default Security Settings.oft) 
as well as a reg file (Security. reg) for setting the registry keys on the client are 
located in compressed format in a Zip file in the Groupware installation directory 
under 
...\ComAssistant Groupware\Exchange\OutlookSec\OutlookSecu
rity.zip.

NOTE:  It is not possible therefore to modify the security settings if the user is 
using a different mail server or a profile with personal folders (.pst file). For further 
information on modifying the security update, refer to: 
www.microsoft.com/office/ork/2000/journ/OutSecUpdate.htm

http://www.microsoft.com/office/ork/2000/journ/OutSecUpdate.htm
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8.4.2.1  Performing Changes on the Exchange Server

You require the appropriate administrative rights on the Exchange Server to 
perform these changes. Carry out the following steps:

1. Log in to the Exchange Server.

2. Check the public folders for a folder called "Outlook Security Settings". If this 
folder does not exist, you have to create it. Set permissions for this folder such 
that all users have read access to it.

3. If the "Outlook Security Settings" folder was already available, check whether 
it contains an object relating to "Default Security Settings".

4. If the "Default Security Settings" object is available, proceed as follows:

a) Open the "Default Security Settings" object. Select the "Programmatic 
Settings" tab.

b) Set the following lines to "Automatically approve": 
"When sending items via Outlook object model" 
"When accessing the address book via CDO" 
"When accessing address information via CDO"

c) Close the form and confirm the save prompt with Yes.

5. If the "Default Security Settings" object is not available, proceed as follows:

a) Open the "Default Security Settings.oft" file in the accompanying 
"Security" folder from Windows Explorer. You will be prompted to select 
an Outlook folder. Choose the folder "Outlook Security Settings".

b) Then, in the window that opens, choose "Tools -> Form -> Publish form".

c) Select the "Outlook Security Settings" folder in the drop-down menu at the 
top of the window.

d) In the "Displayed name" field enter: "Outlook Security Form". Click 
Publish.

6. Close the form and confirm the save prompt with Yes.

SH_CA-GW_04.fm
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8.4.2.2  Performing Changes on the Outlook Host

Carry out the following steps:

1. Unzip the file OutlookSecurity.zip file. You will find the ZIP file in the 
DS-Win installation directory under 
...\DsWin\OutlookSec\OutlookSecurity.zip. The file 
Security.reg is decompressed. 

2. Double-click the file Security.reg. The registry key is set.

8.4.3  Adapting Outlook Options

The Outlook settings that have to be made in Outlook to enable proper use of the 
Groupware functions are described below.

8.4.3.1  Setting the Time Zone

1. In Outlook, select Tools -> Options -> Calendar Options -> Time Zone.

2. Now select "Adjust for daylight saving time" and click OK.

NOTE:  Please note that overlapping dates are not supported.

8.4.3.2  Setting Free/Busy Options

1. In Outlook, select Tools -> Options -> Calendar Options -> Free/Busy 
Options.

2. Set the value for "Update free/busy information on the server every x 
minutes" to the minimum value of 1 minute.

3. Click OK.

8.4.3.3  Check the Setting »Exchange Cache Mode«

1. In Outlook, select the account you want to edit under Tools -> E-mail 
Accounts and click Modify.

2. Make sure that the "Exchange Cache Mode" option is not activated. Change 
this setting if appropriate and click Next to save the settings.
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8.4.3.4  Troubleshooting

Free/Busy information is only issued if the user has at least logged in once to his/
her mailbox and has made at least one calendar entry. This error is output in the 
Outlook.log file as a MAPI_E_NOT_FOUND error.

Log in to the mailbox and create a calendar entry in order to show the following 
workaround options:

The time zone setting can assume one of the following values: 

Time Zone Setting Decimal 
Value

Time Zone is used in Deviation to GMT

CdoTmzAbuDhabi 24 United Arab Emirates + 4:00 

CdoTmzAdelaide 19 Central Australia + 9:30 

CdoTmzAlaska 14 Alaskan time zone (North America) 9:00 

CdoTmzAlmaty 46 Kazakhstan + 6:00 

CdoTmzArizona 38 Arizona (USA) 7:00 

CdoTmzAthens 7 Greece + 2:00 

CdoTmzAtlantic Canada 9 Atlantic time zone (North America) 4:00 

CdoTmzAzores 29 Azores 1:00 

CdoTmzBaghdad 26 Iraq + 3:00 

CdoTmzBangkok 22 Thailand + 7:00 

CdoTmzBeijing 45 Mainland China + 8:00 

CdoTmzBerlin 4 Germany + 1:00 

CdoTmzBogota 35 Columbia 5:00 

CdoTmzBombay 23 India + 5:30 

CdoTmzBrisbane 18 Eastern Australia + 10:00 

CdoTmzBuenosAires 32 Argentina 3:00 

CdoTmzCairo 49 Egypt + 2:00 

CdoTmzCaracas 33 Venezuela 4:00 

CdoTmzCentral 11 Central time zone (North America) 6:00 

CdoTmzDarwin 44 Northern Australia + 9:30 

CdoTmzEastern 10 Eastern Time Zone (North America) 5:00 

CdoTmzEastern Europe 5 Latvia, Lithuania and Romania + 2:00 

CdoTmzEnewetak 39 Enewetak 12:00 

CdoTmzFiji 40 Fiji Islands + 12:00 
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CdoTmzGuam 43 Guam + 10:00 

CdoTmzGMT 1 Greenwich Mean Time, also referred to as UTC 
(Coordinated Universal Time)

+ 0 

CdoTmzHarare 50 Zimbabwe + 2:00 

CdoTmzHawaii 15 Hawaii (North America) 10:00 

CdoTmzHobart 42 Tasmania + 10:00 

CdoTmzHongKong 21 Hong Kong SAR, PRC + 8:00 

CdoTmzIndiana 34 Indiana (USA) 5:00 

CdoTmzIslamabad 47 Pakistan + 5:00 

CdoTmzIsrael 27 Israel + 2:00 

CdoTmzKabul 48 Afghanistan + 4:30 

CdoTmzLisbon 2 Portugal + 0 

CdoTmzMagadan 41 Eastern Russia + 11:00 

CdoTmzMax 52 Unused time zone (not a valid setting)

CdoTmzMexicoCity 37 Central and Eastern Mexico 6:00 

CdoTmzMidAtlantic 30 Central Atlantic Islands 2:00 

CdoTmzMidway Island 16 Midway Islands 11:00 

CdoTmzMonrovia 31 Liberia + 0 

CdoTmzMoscow 51 West-Russia + 3:00 

CdoTmzMountain 12 Mountain Time Zone (North America) 7:00 

CdoTmzNewfoundlad 28 Far Eastern Canada 3:30 

CdoTmzOrigin 0 International Date Line, where each calendar 
day begins (not a valid setting).

+ 12:00 

CdoTmzPacific 13 Pacific time zone  
(North America) 

8:00 

CdoTmzParis 3 France + 1:00 

CdoTmzPrague 6 Czech Republic + 1:00 

CdoTmzRiode Janeiro 8 Brazil 3:00 

CdoTmzSaskatchewan 36 Saskatchewan (Canada) 6:00 

CdoTmzTehran 25 Iran + 3:30 

CdoTmzTokyo 20 Japan + 9:00 

CdoTmzWellington 17 New Zealand + 12:00 

Time Zone Setting Decimal 
Value

Time Zone is used in Deviation to GMT
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To use presence management with Outlook 2007, please install 
ExchangeCdo.MSI. For licensing reasons, this installation package must be 
acquired directly from Microsoft:

www.microsoft.com/downloads/details.aspx?familyid=2714320d-c997-4de1-
986f-24f081725d36&displaylang=en

8.4.4  Notes on Microsoft Outlook / Microsoft 
Exchange Server

The following notes apply for Microsoft Outlook 2003/2007 operation with 
Security Patches and Microsoft Outlook 2003/2007 in conjunction with Microsoft 
Exchange Server.

The following Outlook message occurs when operating DS-View but can be 
avoided by modifying the security settings.

For this to work, the following requirements must be fulfilled:

1. You must make an entry in the public folder: Public Folders\All Public 
Folders\Outlook Security Settings. The default entry is "Default Security 
Settings". You can define exceptions with further entries.

This entry depends on the operational security guidelines and configuration 
requirements.

The DS-View User’s Guide A31003-G6640-U100-*-**19 contains examples 
of the minimum requirements for running DS-Win V4.0.

The security settings for Outlook with Security Patch can be changed 
centrally on the Exchange Server.

Outlook 2003 without Security Patch is not affected by the settings.

http://www.microsoft.com/downloads/details.aspx?familyid=2714320d-c997-4de1-986f-24f081725d36&displaylang=en
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2. DS-Win V4.0 sets a registry key to eliminate the following warning from 
Outlook when DS-Win V4.0 is running.

This entry is as follows:

[HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Security]

"CheckAdminSettings"=dword:00000001

Alternatively, the following entry can also be used:

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Security]

"CheckAdminSettings"=dword:00000001

to eliminate the warning for a specific user only.

3. The modified security settings apply once you start Outlook again.
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8.5  Adding a New Language

Introduction

To create a new language for DS-Win, the service technician must edit or create 
new XML files and generate new language files. Deeper intervention in the 
system is not required.

Activating a New Language for DS-Win

Proceed as follows:

Step Action

1 Edit the languageMapping.xml file:

1. Open the languageMapping.xml file. The file is located in the following directory:

• For Windows Vista (example for English operating systems):  
C:\ProgramData\Unify\DS-Win V4\Config\

• For Windows XP (example for English operating systems):  
C:\Documents and Settings\All Users\Unify\DS-Win V4\Config\

• For Windows 7 (example for English operating systems): 
C:\ProgramData\Unify\DS-Win V4\Config\

2. Look for the following entry in the languageMapping.xml file (e.g.,  for Danish):

<entry key="lang_used_2">0</entry>

<entry key="lang_loc_key_2">DSW_LANG_DANISH</entry>

<entry key="lang_name_2">da</entry>

<entry key="country_name_2">DK</entry>

<entry key="font_name_2">Arial Unicode MS</entry>

3. Set the value for the lang_used_2 entry from 0 to 1.

The new language, e.g.,  Danish, will now appear as a menu item and can be selected. The 
lang_name_2 and country_name_2 entries must not be changed, since their values correspond to 
the ISO 639 and 3166 Standards.
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2 Create language files for the new language:
Three new language files are required for a new language. These are (e.g.,  for Danish): 
DSView_text_da.properties, DSWin_Admin_text_da.properties, MCSync_text_da.properties. 
The sample abbreviation da stands for Danish as per ISO 639.

1. Open the default language file <InstDir>\Data\Localization\ 
DSView_text.properties.

2. Enter the texts for the new language (e.g., for Danish),  but do not save the file as yet. Enter the 
special characters of a language in Unicode format; see http://www.fileformat.info/info/unicode/
char/a.htm.

3. Save the file as a new file with the following name: 
<InstDir>\Data\Localization\DSView_text_da.properties

4. Perform steps 1 to 3 for the following files as well:

• DSWin_Admin_text.properties -> DSWin_Admin_text_da.properties

• MCSync_text.properties -> MCSync_text_da.properties

3 Generate XML file for the user interface:
The operation of the GUI Designer is described in the "DS-Win V4, GUI Designer" User’s Guide.

1. Start GUI Designer.

2. Create a new XML file in GUI Designer via File -> New and save it under:

• For Windows Vista (example for English operating systems):  
C:\ProgramData\Unify\DS-Win V4\Data\Forms\

• For Windows XP (example for English operating systems):  
C:\Documents and Settings\All Users\Unify\DS-Win V4\Data\Forms\

• For Windows 7 (example for English operating systems):  
C:\Program Data\Unify\DS-Win V4\Data\Forms\

3. Edit and save the XML file in GUI Designer.

4. Set the XML file as the default in the DS-Win Configuration program (via Start -> Programs -> 
DS-WinV4 -> DS-Win Configuration). DS View can now be opened with this XML file.

Step Action

http://www.fileformat.info/info/unicode/char/a.htm
http://www.fileformat.info/info/unicode/char/a.htm
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Activating a New Language for the GUI Designer

Proceed as follows:

Step Action

1 Open the file <InstDir>\Data\Localization\Designer\langs.xml.

2 Extend the langs.xml file with:
• Menu items for all existing languages:

• New "Language" entry, e.g.,  for Danish:

3 Save the langs.xml file and close it.

4 Create a language.da file (da for Danish):

1. Create a copy of an existing language file (e.g.,  of the language.en file).

2. Rename the copy of the language file to language.da.

3. Translate all values in the language.da file into the desired language (Danish in this case).

4. Save the language.da file and close it.

<Languages>
<Language iso="en" used="true">
<Menu iso="en" text="English"/>
<Menu iso="de" text="German"/>
<Menu iso="it" text="Italian"/>
<Menu iso="hu" text="Hungarian"/>
</Language>
<Language iso="de" used="true">
<Menu iso="en" text="Englisch"/>
<Menu iso="de" text="Deutsch"/>
<Menu iso="it" text="Italienisch"/>
<Menu iso="hu" text="Ungarisch"/>
</Language>
<Language iso="it" used="true">
<Menu iso="en" text="Inglese"/>
<Menu iso="de" text="Tedesco"/>
<Menu iso="it" text="Italiano"/>
<Menu iso="hu" text="Ungherese"/>
</Language>
<Language iso="hu" used="true">
<Menu iso="en" text="Angol"/>
<Menu iso="de" text="Német"/>
<Menu iso="it" text="Olasz"/>
<Menu iso="hu" text="Magyar"/>
</Language>
</Languages>

<Language iso="da" used="true">
<Menu iso="en" text="Engelsk"/>
<Menu iso="de" text="Tysk"/>
<Menu iso="it" text="Italiensk"/>
<Menu iso="hu" text="Ungarsk"/>
</Language>
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8.6  DS-Win and BLF-Win

DS-Win can be used with BLF-Win. You will find the settings for this under Tools 
-> Application settings -> BLF-Win.

8.7  Providing Data to the Development Department (General Ticket 
Procedure)

Current Information in the Intranet

The current information on how to provide data to the development department 
you find in the Intranet on the following page: http://prodsu.mch4.global-intra.net/ 
-> Checklists -> Checklist for AC-WIN Suite (AC-WIN, DS-WIN, BLF-WIN)

DS-Win Installation Directory and Data Directory

During the installation of DS-Win V4, two directories were created:

• The <InstDir> installation directory into which DS-Win V4 was installed: 
C:\Program Files (x86)\Siemens\DS-Win V4\

• The <DataDir> data directory which DS-Win V4 uses to store the data (in 
Windows Vista und Windows 7): 
C:\ProgramData\Siemens\DS-Win V4\

This directory is a hidden folder in Windows. If you cannot see it, you must 
display it.

Provide Data

1. Provide all data from the <DataDir>\Log directory. If possible, create a zip 
file which includes all of these data.

2. In addition, provide the following data which depend on the problem. If 
possible, create a zip file which includes all of these data:

• If problems occur with the Database Migration:

– DS-Win database

– All scripts from<DataDir>\Script

NOTE:  Important: If this folder is empty, make sure that in the "DS-Win Admin-
istration" application the retain script files parameter is set with a valid 
value (Start -> Programs -> DS-Win V4 -> DS-Win Admin -> Options -> Appli-
cation Settings).

• If problems occur with the Database Import:

http://prodsu.mch4.global-intra.net/
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– The used import files in the .txt or .csv format

– In addition, describe the import problem and the specifications. If the 
default database (db) was modified, this database must be also sent 
to the developers.

• If problems occur with the Synchronization:

– DSWin2.rsp

– DSWin2_I.dat

The path of these files is defined in the synchronization specification. The 
<DataDir> folder is the default folder.

• If problems occur with the Printing function:

– Template files from the <DataDir>\templates directory

• If problems occur with the User interface, if the default user interface is 
not used:

– GUI.xml from the <DataDir>\Data\Forms directory

– DataSources.xml from the <DataDir>\Data\DBDesc directory

– DbTables.xml from the <DataDir>\Data\DBDesc directory

– DSWin_View_config.xml from the <InstDir>\Config\ 
directory
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9  Notes on Databases

9.1  Opening External Databases

External databases – i. e., databases which are not DS-Win databases – can be 
opened by the administration and via the data view window if all required drivers 
are installed.

9.2  Database Structure

9.2.1  Deleting Fields from the Default Tables

Fields that are not used internally can be deleted from the default tables.

9.2.2  Modifying the Table Structure of Filled Tables

It is only possible to modify the structure of an empty table. If a table already 
contains data, proceed as follows (basic sequence of operations):

Step Action

1 Export the data from the table (all fields).

2 Delete all data from the table (empty the table).

3 Modify the table structure.

4 Create a new import specification.

5 Reimport the data.
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9.2.3  Index Generation

Indices increase the search speed but slow down the administration.

The "Columns" search fields in the "CSearchPanel" component require an index. 
When working with partitions, an additional index must be entered for every field 
in the "CSearchPanel" component:

• The first index for searching without partitions only contains the 
corresponding search field in the first position.

• The second index for searching with partitions requires the partition field in 
the first position and the corresponding search field in the second position.

Example:

You want to search in the "Sort name" field using the "CSearchPanel" 
component. The "Partition" field has been selected as the partition field:

• The first index contains the "Sort name" database field in first position.

• The second index contains the "Partition" database field in first position and 
the "Sort name" field in the second position.

These two indices must be selected in the "Columns" property dialog of the 
"CSearchPanel" component (property fields "Index name" or "Partition index 
name").  
This SearchPanel must also be selected in the "PartitionSearchPanel" property 
of the "DSWinControlPanel" component.
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9.3  Data Exchange

9.3.1  Exporting Data

General

When exporting data, all fields in the specified table are always exported 
(exception: counter fields and OLE fields), regardless of the specification 
settings.

Memo Fields

If tables with memo fields are exported, a text separator should always be given 
in the specification since otherwise there might be problems with importing this 
data.

9.3.2  Importing Subscriber Data

When importing subscriber data, the "SubscriberID" field should not be imported 
if the data is being transferred for the first time (Refill table). The "SubscriberID" 
field is filled automatically. It is required for interrelating with other tables (Product, 
CRSubsProd...) or for update purposes.

9.3.3  Importing Data with Field Names

Beim Importieren von Daten mit Feldüberschriften werden die Felder der Datei 
anhand der Feldüberschriften importiert. Die Spezifikationseinstellungen, wie 
„Überspringen”, „Feldanordnung”, „Anzahl der Felder ...” werden nicht 
berücksichtigt.
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9.3.4  Importing/Synchronizing with Default Values

Default values can be specified during import and synchronization.

During import the defaults for specification are entered in the "Presetting" field. 
Invalid default values trigger an error message:

For synchronization, the default values are entered in the "Field Mapping" window 
under Synchronization settings. The default values are entered in inverted 
commas ("") in the "HostName" field (e. g. "Unify") and assigned to a DS-Win field:

Field name Type Length Skip Default

SubscriberID Long Integer 4 Yes

Partition Text 30 Yes Berlin

MasterID Text 15 Yes

MasterSource Text 128 Yes 198.7.1.59

Company Text 30 Yes Unify AG

etc. etc. etc. etc.

HostName DSWinName

building Building

christianname Firstname

"Unify" Company

etc. etc.
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9.4  MSysCountry Table and MSysMappingTable

These two tables can only be administered by users who have specific 
authorization. The user must have at least the "Design database structure" 
permission. The assignments in the MSysMappingTable are used for 
synchronizing subscriber tables if no special assignment has been specified for 
the synchronization settings.
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9.5  Converting Umlauts

Umlauts can now be converted in all text fields in all tables.

Under Tables -> Design, the "Umlaut mode" can be switched from German to 
Default in the Table properties to change the data sort sequence. The umlaut 
mode can only be modified in combination with a format rule and uppercase 
letters.

The German umlaut mode sorts the umlauts ä, ö and ü as ae, oe and ue, 
respectively, and ß as ss. This is the usual sorting found in the German phone 
directory. The Default umlaut mode produces an alphabetical sorting, i. e., ä, ö 
and ü are handled as a, o and u. This sort sequence is also used in the German 
dictionary.

If the German umlaut mode is used for a field in the database, then the same 
umlaut mode must also be activated in the data view (DSView) in the search 
panel; otherwise, the search for umlauts will not work properly.  To do this, select 
SearchPanel in Design mode and click "Columns" under "Properties" and open 
the "Columns of Search Panel" window. The required "SearchColumn" must be 
clicked here and Umlautmode=umGerman can then be set on the right under 
"Column Properties".
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10  Technical Data

10.1  Characteristics of DS-Win V4

10.1.1  Block Diagram of DS-Win V4

NOTE:  The DS-Win dial interface can only be configured for AC-Win or the data 
adapter of the phone.
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10.1.2  Limit Values

Database

Data View (Dialog File)

Maximum length of text fields: 10485760 characters

Maximum/minimum values of integer fields: +/- 32 767

Maximum/minimum values of long fields: +/- 2 147 483 647

Maximum size of memo fields: 1 GB data

Maximum number of data records: 200 000  
(it is possible to administer more than this maximum number of 
data records, however the performance is considerably 
reduced)

Maximum number of new tables: 25

Compound indices: May be allocated across a maximum of 8 fields.

Maximum number of indices per table: 30 (performance problem)

Maximum number of fields per table: 100

Table 3 Limit Values of the Database

Maximum number of databases: 3

Maximum number of datasets: 15

Maximum number of data sources: 15

Maximum number of tab sheets: 8

Maximum number of sub-lines per output table: 10

Minimum height of row when using markers: 16 pixels  
(if the row height is less, the markers are no longer 
displayed)

Maximum number of columns per output table: 50

Table 4 Limit Values of Data View(Dialog File)
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